summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMingi Sung2023-08-08 15:59:09 +0900
committerMingi Sung2023-08-08 16:01:52 +0900
commit02e619f2b06653989ebdf899f47ecc4f90372caa (patch)
tree998d221560adff50a24b549173ba3881706426ec /PKGBUILD
parentce9d6f6280708d4f0e3d5d05b76f6eec9cc9f964 (diff)
downloadaur-02e619f2b06653989ebdf899f47ecc4f90372caa.tar.gz
1:44.3-3: Add mr3113 and mr3132
Signed-off-by: Mingi Sung <fiestalake@disroot.org>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 22 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86f82ece564e..2a8db03d85a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,8 @@
### PACKAGE OPTIONS
## MERGE REQUESTS SELECTION
-# Merge Requests List: ('579' '1441' '3105' 'revert-2878-partially' 'prio')
-_merge_requests_to_use=('1441' '3105' 'prio')
+# Merge Requests List: ('579' '1441' '3105' '3113' '3132' 'revert-2878-partially' 'prio')
+_merge_requests_to_use=('1441' '3105' '3113' '3132' 'prio')
## Disable building the DOCS package (Enabled if not set)
# Remember to unset this variable when producing .SRCINFO
@@ -32,7 +32,7 @@ else
fi
epoch=1
pkgver=44.3
-pkgrel=2
+pkgrel=3
pkgdesc="A window manager for GNOME | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync"
url="https://gitlab.gnome.org/GNOME/mutter"
arch=(x86_64 aarch64)
@@ -76,10 +76,14 @@ _commit=99d83f2985483bc192e1271665c442c7c480a588 # tags/44.3^0
source=("$pkgname::git+https://gitlab.gnome.org/GNOME/mutter.git#commit=$_commit"
'mr1441.patch'
'mr3105.patch'
+ 'mr3113.patch'
+ 'mr3132.patch'
'prio.patch')
sha256sums=('SKIP'
'a6e07de13e44a721f235f557882ca7ef050324dcd3532fb278d677aba71abd80'
'1f90bf7402a940b086743d63ccfa8a90c71f24ae2cc26293e990196778d0176a'
+ '1edb49dfb19bd30208c823eca87fb1f930c4d3dbc559e3c1a5707a824646f399'
+ '7eb6665b368c7ebb8cac5327819a63ae9091cfeb2e8add832bd01d9507a2cdd2'
'cca15ee32b5b4d942960672ab37403b2ccf5d249711fc321b333c3936d9ab897')
pkgver() {
@@ -172,6 +176,13 @@ prepare() {
# Comment: See https://gitlab.gnome.org/GNOME/mutter/-/issues/2690
pick_mr 'revert-2878-partially' 3ac82a58c51a5c8db6b49e89a1232f99c79644cc 'revert'
+ # Title: Backports for 44.4
+ # URL: https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3132
+ # Type: 3
+ # Status: 2
+ # Comment: !3125(merged), !3117(merged), !3096(merged), !3035(merged)
+ pick_mr '3132' 'mr3132.patch' 'patch'
+
# Title: core: Only avoid focusing x11 windows on map
# Author: two <two@envs.net>
# URL: https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3105
@@ -180,6 +191,14 @@ prepare() {
# Comment: See https://gitlab.gnome.org/GNOME/mutter/-/issues/2690
pick_mr '3105' 'mr3105.patch' 'patch'
+ # Title: core: Only force placement of windows that should be mapped
+ # URL: https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3113
+ # Type: 3
+ # Status: 2
+ # Comment: This addresses #2579 for forced placement in the X11 session, without
+ # reintroducing #2611.
+ pick_mr '3113' 'mr3113.patch' 'patch'
+
# Title: Draft: Dynamic triple/double buffering (v4)
# Author: Daniel van Vugt <daniel.van.vugt@canonical.com>
# URL: https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/1441