summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTérence Clastres2019-10-20 23:49:26 +0200
committerTérence Clastres2019-10-21 01:06:24 +0200
commit9fd4483e91b3b4537a0632009bb459305a2307b0 (patch)
tree62a7ef5c0afcc795529eae4d3fc901eb047ac74d /PKGBUILD
parent6769a4df4b670a3d564a203a6469c477b2f45163 (diff)
downloadaur-9fd4483e91b3b4537a0632009bb459305a2307b0.tar.gz
Sync to gnome-3.34
Fix compilation error with mesa >= 19.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aca0c9d6bff4..cf7c549a05ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Michael Kanis <mkanis_at_gmx_dot_de>
pkgname=mutter-performance
-pkgver=3.34.0+82+g65cc8c1ea
+pkgver=3.34.1+26+gc0037305e
pkgrel=1
pkgdesc="A window manager for GNOME | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync"
url="https://gitlab.gnome.org/GNOME/mutter"
@@ -22,9 +22,11 @@ provides=(mutter mutter-781835-workaround)
conflicts=(mutter)
replaces=(mutter-781835-workaround)
groups=(gnome)
-_commit=65cc8c1ea2e6462349355142f17992101ef634ce # master
-source=("$pkgname::git+https://gitlab.gnome.org/GNOME/mutter.git#commit=$_commit")
-sha256sums=('SKIP')
+_commit=c0037305ebd9b742f8d133d810192022878efe8e # master
+source=("$pkgname::git+https://gitlab.gnome.org/GNOME/mutter.git#commit=$_commit"
+ fix-build.patch)
+sha256sums=('SKIP'
+ '28aa24daed161f2566ca2b159beb43285184c533956b851a7eb318de741da935')
pkgver() {
cd $pkgname
@@ -126,6 +128,8 @@ prepare() {
git revert ce86f90efbaa51522ba14c5b4cad933c2106de42 --no-commit
fi
+ patch -Np1 < ../fix-build.patch
+
}
build() {