summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuoYi2022-01-08 10:00:58 +0800
committerLuoYi2022-01-08 10:00:58 +0800
commit296781c0a59754427d1198cc096d17e99f2c1a7a (patch)
treede4d45b580ff4e32942ab01440a6de6085682a7d /PKGBUILD
parenta2a2d345199abdb2179150fc6e0d54d5286317a0 (diff)
downloadaur-296781c0a59754427d1198cc096d17e99f2c1a7a.tar.gz
Upgrade to 41.2-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2bcf586d9339..b130735c3756 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=mutter-rounded
pkgver=41.2
-pkgrel=1.1
+pkgrel=2
pkgdesc="A window manager for GNOME, with rounded corners patch"
url="https://gitlab.gnome.org/GNOME/mutter"
arch=(x86_64)
@@ -15,9 +15,9 @@ license=(GPL)
depends=(dconf gobject-introspection-runtime gsettings-desktop-schemas
libcanberra startup-notification zenity libsm gnome-desktop upower
libxkbcommon-x11 gnome-settings-daemon libgudev libinput pipewire
- xorg-xwayland graphene libxkbfile)
+ xorg-xwayland graphene libxkbfile libsysprof-capture)
makedepends=(gobject-introspection git egl-wayland meson xorg-server
- wayland-protocols)
+ wayland-protocols sysprof)
checkdepends=(xorg-server-xvfb wireplumber python-dbusmock)
provides=(libmutter-9.so mutter)
conflicts=(mutter)
@@ -75,8 +75,7 @@ build() {
arch-meson $pkgname build \
-D egl_device=true \
-D wayland_eglstream=true \
- -D installed_tests=false \
- -D profiler=false
+ -D installed_tests=false
meson compile -C build
}
@@ -97,7 +96,7 @@ _check() (
)
check() {
- dbus-run-session xvfb-run -s '-nolisten local' \
+ dbus-run-session xvfb-run -s '-nolisten local +iglx -noreset' \
bash -c "$(declare -f _check); _check"
}