summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:14:57 -0700
committerAaron DeVore2015-07-08 11:14:57 -0700
commit95d16fe6ae5cae4ec9af931e9af4ba80a5094359 (patch)
tree151a3101a973676780f7f9adc034e768e9c7a5d2 /PKGBUILD
downloadaur-95d16fe6ae5cae4ec9af931e9af4ba80a5094359.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad290c206137
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
+# Contributor: Mathieu Clabaut <mathieu.clabaut@gmail.com>
+pkgname=mwlib.rl
+pkgver=0.14.3
+pkgrel=1
+pkgdesc="Converts MediaWiki articles to pdf, odf, and docbook"
+arch=('any')
+url="http://code.pediapress.com/wiki/wiki"
+license=("BSD")
+depends=('python2' 'mwlib.ext' 'texvc' 'python2-pygments' 'fribidi' 'ploticus'
+'imagemagick' 'ghostscript' 'ocaml' 'mwlib')
+makedepends=('mercurial' 'python2-distribute' 'python2-docutils')
+source=("http://pypi.python.org/packages/source/m/$pkgname/$pkgname-$pkgver.zip"
+ 'license.txt')
+md5sums=('26954d7d58ed2f1c00bc9c4c9ee2630b'
+ '472b2de7c34ecbd590240179882e36f8')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir"
+ install -D -m644 "$srcdir/license.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+}
+