summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornoirscape2020-06-28 00:32:59 +0200
committernoirscape2020-06-28 00:32:59 +0200
commit42966381f992a0063f70a8d1ee255a0bb00330a3 (patch)
tree359586d27405260655a2450f7c92a999bc0010f8 /PKGBUILD
parentb219a210b4d1fef5f56feb7ad845ffda866bf2b0 (diff)
downloadaur-42966381f992a0063f70a8d1ee255a0bb00330a3.tar.gz
1.10.10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d77533867794..f6bf044a50f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
+# Maintainer: Justin Kromlinger <mail at hashworks dot net>
+# Contributor: Valentijn "noirscape" V. <neko at catgirlsin dot space>
pkgname=mwoffliner
-pkgver=1.10.7
+pkgver=1.10.10
pkgrel=2
pkgdesc="Mediawiki/Parsoid HTML snapshot utility and ZIM file builder"
arch=(any)
@@ -9,14 +11,24 @@ depends=('zimwriterfs>=1.3.7' 'nodejs' 'npm' 'jpegoptim' 'advancecomp' 'gifsicle
optdepends=()
source=(https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
noextract=($pkgname-$pkgver.tgz)
-sha256sums=(f5e99dc1ead060d590108b12c25d8006d8b4bac2338a47170e19c2219626f5d9)
+sha256sums=('6ccf04716fb675b642ddc4a8caecab68d43185e3a7e803ac98c195b7b8a4a690')
+makedepends=('jq')
package() {
cd $srcdir
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p $_npmdir
cd $_npmdir
- npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
+ npm install -g --cache "${srcdir}/npm-cache" --prefix "$pkgdir/usr" $pkgname@$pkgver
+
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ local tmppackage="$(mktemp)"
+ local pkgjson="$pkgdir/usr/lib/node_modules/$pkgname/package.json"
+ jq '.|=with_entries(select(.key|test("_.+")|not))' "$pkgjson" > "$tmppackage"
+ mv "$tmppackage" "$pkgjson"
+ chmod 644 "$pkgjson"
}
+
+
# vim:set ts=2 sw=2 et: