summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Mogas da Silva2017-10-24 21:33:59 +0100
committerCarlos Mogas da Silva2017-10-24 21:33:59 +0100
commit181df778a69e98751715994c8bd7226c721002ff (patch)
tree1603d953b3564494502bd8a8491b557f26d6753f /PKGBUILD
parentd108ff946b26d00bdfecb8ff4b7c8cd405f45e35 (diff)
downloadaur-181df778a69e98751715994c8bd7226c721002ff.tar.gz
Add tmpfiles file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b7d7ce376a01..08e28d89bf04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mxisd
pkgver=0.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="Federated Matrix Identity Server Daemon"
arch=('any')
url="https://github.com/kamax-io/mxisd"
@@ -10,7 +10,8 @@ license=('AGPL3')
depends=('java-runtime>=8')
makedepends=('gradle' 'java-environment>=8')
source=("https://github.com/kamax-io/${pkgname}/archive/v${pkgver}.tar.gz"
- "mxisd")
+ "mxisd"
+ "mxisd.tmpfiles")
sha256sums=('436f0ea7d2ff6deac5846c72de21c04f71eab9d05c71f3716c2b33195601666b'
'8d24a31f14dcdf85b4841e9412254e3cab357391b7e01886e54c04a6fb3cbc2e')
install='mxisd.install'
@@ -41,7 +42,8 @@ package() {
install -m 644 application.example.yaml "${pkgdir}"/etc/mxisd/mxisd.yaml.example
# Systemd
- install -dm 755 "${pkgdir}"/usr/lib/systemd/system
+ install -dm 755 "${pkgdir}"/usr/lib/{systemd/system,tmpfiles.d}
install -m 644 src/systemd/mxisd.service "${pkgdir}"/usr/lib/systemd/system/mxisd.service
+ install -m 644 mxisd.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/mxisd.conf
}