summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGodisemo2017-02-11 01:11:20 +0100
committerGodisemo2017-02-11 01:11:20 +0100
commit0d8e3b427e3ef8d5ff4d5728a44dabeb09f05461 (patch)
treee001a26bcc8edd63323901d9fcf0ebdf7327c448 /PKGBUILD
downloadaur-0d8e3b427e3ef8d5ff4d5728a44dabeb09f05461.tar.gz
Initial commit of v0.9.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0933f14545e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Carl Ã…kerlindh <carl.akerlindh at gmail dot com>
+pkgname=mxnet
+pkgver=0.9.3
+pkgrel=1
+pkgdesc="Flexible and Efficient Library for Deep Learning"
+arch=('x86_64')
+url="http://mxnet.io/"
+license=('Apache2')
+depends=(cuda cudnn)
+# makedepends=()
+# checkdepends=()
+# optdepends=()
+# provides=()
+source=("$pkgname::git+https://github.com/dmlc/mxnet")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+ git checkout "v$pkgver"
+ git submodule update --init --recursive
+ cp make/config.mk .
+ echo "USE_CUDA=1" >>config.mk
+ echo "USE_CUDA_PATH=/opt/cuda" >>config.mk
+ echo "USE_CUDNN=1" >>config.mk
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make -j$(nproc)
+}
+
+package() {
+ cd "$pkgdir"
+ install -D "$srcdir/$pkgname/lib/libmxnet.so" "$pkgdir/usr/lib/libmxnet.so"
+}
+