summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Reggiani Manzo2016-12-30 09:12:22 -0200
committerRafael Reggiani Manzo2016-12-30 09:12:22 -0200
commit5a2441f555d869e52e40577bb8471da118d7c3e9 (patch)
tree551c3920866219543b8db822d909e782f319999d /PKGBUILD
parent556df9f7b8d74dc4e7d502a57608f4e05613b8eb (diff)
downloadaur-5a2441f555d869e52e40577bb8471da118d7c3e9.tar.gz
Upgrade to v0.8.0
This upgrade raised the issue of permission setting on the install script causing warnings as the package has no knowledge about it. A warning has been added about the new expected identification file name.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02f0c2251ca5..1d33768bc238 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Rafael Reggiani Manzo <rr.manzo#protonmail.com>
pkgname=mycroft-core
-_pkgcommit=eb0a37c
-pkgver=0.7.20.${_pkgcommit}
+# _pkgcommit=eb0a37c # Used only when the latest tag is not working
+# pkgver=0.7.20.${_pkgcommit}
+pkgver=0.8.0
pkgrel=1
pkgdesc="Mycroft Core, the Mycroft Artificial Intelligence platform. Contribute to this package at: https://gitlab.com/rafamanzo/aur-mycroft-core"
arch=('i686' 'x86_64')
@@ -33,35 +34,38 @@ optdepends=()
conflicts=()
install=mycroft-core.install
# changelog=ChangeLog
-# FIXME: The tarball is outdated and not able to pair with home.mycroft.ai
-#source=("https://codeload.github.com/MycroftAI/mycroft-core/tar.gz/release/${pkgver}")
-#sha512sums=('cd86a76b4131db1b5a172b617ee8ff46d60b8094b8dec9e3a88fe976f7d6c4d9b65b44fd62984d1ce5c8c761f15a341291677b9c1bccc50fead80727b474bca5')
-source=("git://github.com/MycroftAI/mycroft-core.git#commit=${_pkgcommit}"
+source=("https://codeload.github.com/MycroftAI/mycroft-core/tar.gz/release/v${pkgver}"
+#source=("git://github.com/MycroftAI/mycroft-core.git#commit=${_pkgcommit}" # Used only when the latest tag is not working
"mycroft.target"
"mycroft-service.service"
"mycroft-skills.service"
"mycroft-voice.service")
-sha512sums=(SKIP # Git already ensures data consistency
+sha512sums=(e2a3044a482cff7a2d68451aba7e776e4f8d5236d6e00add4977354565b91c177753abd22048c24b5ffc28d9664bb38d00a73f199ff184ed8f5a19b912ec9305
+# sha512sums=(SKIP # Git already ensures data consistency # Used only when the latest tag is not working
a5989c9ff2b0f7338b4a6f9342c980413d71da375355abb416dce3a79e298fea7872e39b6a1505437aab860ed66755a6f344821f4f7cb31aed46792b2cef3f96
74e9451dc38560e6efd4baf8c77cb81bdf9c0b821c1935eb2dac060614c0f14458101151583c3f444da59d9f065a744a7ad6f8daaeceec8f4e37f67d33199b6b
cb8a5c2245ecd52e66acedebf7ce6ce8db32a84b3495d34cc3749e03aa7d12c958b5f71fa01aa79b36906401e655dd6442e979d60d53d64160d9f956551a92df
7266494bf416a6f969bcbe9e854753e2a7e498ff9b43d6ca0ba37d94736bca9bf35f5825f24e19138428728189814222f2592fdea4c7e1d0d0ad18e7d3606a0b)
# Valid only when using a tarball
-# prepare(){
-# tar xzfv "${pkgver}"
-# }
+prepare(){
+ tar xzfv v${pkgver}
+}
# build() {}
package() {
mkdir -p ${pkgdir}/usr/share/
- cp -R mycroft-core ${pkgdir}/usr/share/
+ # cp -R mycroft-core ${pkgdir}/usr/share/ # Used only when the latest tag is not working
+ cp -R mycroft-core-release-v${pkgver} ${pkgdir}/usr/share/mycroft-core
# Place a link to mimic where mycroft is expecting it
mkdir -p ${pkgdir}/usr/share/mycroft-core/mimic/bin
ln -s /usr/bin/mimic ${pkgdir}/usr/share/mycroft-core/mimic/bin/mimic
+ # Set permissions
+ chmod g+w ${pkgdir}/usr/share/mycroft-core
+
# Symtemd units
install -D -m644 "${srcdir}/mycroft.target" "${pkgdir}/usr/lib/systemd/user/mycroft.target"
install -D -m644 "${srcdir}/mycroft-service.service" "${pkgdir}/usr/lib/systemd/user/mycroft-service.service"