summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-14 04:11:42 +0300
committerDimitris Kiziridis2020-05-14 04:11:42 +0300
commit469c48c05a77a004419118a443e6b1ca5e996884 (patch)
treefe45a709d0db4fac0ef8f9985fd8723605b21fac /PKGBUILD
parente318c2cd2ea9be6f17ca914945af3f1b01746a42 (diff)
downloadaur-469c48c05a77a004419118a443e6b1ca5e996884.tar.gz
sanitize pkgbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c780fead9ad..7f76bf5eec8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,11 @@
pkgname=mylg-git
pkgver=0.2.6.r60.gfaba867
pkgrel=1
-pkgdesc="myLG is an open source software utility which combines the functions of the different network probes in one network diagnostic tool"
+pkgdesc="An open source software utility which combines the functions of the different network probes in one network diagnostic tool"
arch=('x86_64')
url='http://mylg.io'
license=('MIT')
+depends=('libpcap')
makedepends=('go-pie' 'git' 'dep')
source=("git+https://github.com/mehrdadrad/mylg")
sha256sums=('SKIP')
@@ -21,7 +22,9 @@ prepare() {
ln -rTsf ${pkgname%-git} gopath/src/github.com/${pkgname%-git}/${pkgname%-git}
export GOPATH="$srcdir"/gopath
cd gopath/src/github.com/${pkgname%-git}/${pkgname%-git}
- dep init -v
+ if [[ ! -f Gopkg.toml ]]; then
+ dep init -v
+ fi
dep ensure -v
}
@@ -33,5 +36,5 @@ build() {
package() {
install -Dm755 "${srcdir}/gopath/bin/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
- install -Dm644 "${srcdir}/${pkgname%-git}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
+ install -Dm644 "${srcdir}/${pkgname%-git}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file