summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-06-12 06:53:03 +0200
committerhaawda2018-06-12 06:53:03 +0200
commit1f3f6597f27bf535180ad28ddf93e23914af5219 (patch)
tree4e17cad8b8cc61066fbad490e5c856d8467e2d26 /PKGBUILD
parentc634545af01af3d3e3ada6687c1d6bae8f708987 (diff)
downloadaur-1f3f6597f27bf535180ad28ddf93e23914af5219.tar.gz
fix icon in desktopfile
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86baa44bff58..80034184ae16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mystuff
pkgver=3.1
-pkgrel=3
+pkgrel=4
pkgdesc="Create a custom menu in a popup window"
url="http://www.kornelix.net/mystuff/mystuff.html"
arch=('i686' 'x86_64')
@@ -12,9 +12,14 @@ source=("http://www.kornelix.net/downloads/tarballs/$pkgname-$pkgver.tar.gz")
sha256sums=('63eb50580c806006736ce4f8b9d97c97f8506ce8103bf0be2260221ded21376f')
options=('!emptydirs')
-build() {
+prepare() {
cd $pkgname-$pkgver
sed -i 's+xdg-deskto+#xdg-deskto+' Makefile
+ sed -i "s/Icon=\/usr\/share\/mystuff\/icons\//Icon=\/usr\/share\/pixmaps\//" ./mystuff.desktop
+}
+
+build() {
+ cd $pkgname-$pkgver
make PREFIX=/usr LDFLAGS="-lpthread" ICONDIR=/usr/share/pixmaps
}