summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:37:08 +0200
committerStefan Husmann2015-06-09 00:37:08 +0200
commitffde26a32816faea86ae4696ccb045df9c0eeabe (patch)
tree51981d0e4d42e92b740e975931b70e9a938e1890 /PKGBUILD
downloadaur-ffde26a32816faea86ae4696ccb045df9c0eeabe.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7946c9928499
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=mystuff
+pkgver=2.0
+pkgrel=1
+pkgdesc="Create a custom menu in a popup window"
+url="http://www.kornelix.com/mystuff"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('gtk3')
+source=("http://www.kornelix.com/uploads/1/3/0/3/13035936/$pkgname-$pkgver.tar.gz")
+md5sums=('47cf364a1b9fe3b1a4b5827f841a63a7')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ sed -i 's+xdg-deskto+#xdg-deskto+' Makefile
+ sed -i 's+/usr/share/mystuff/icons/++' desktop
+ make PREFIX=/usr LDFLAGS="-lpthread" ICONDIR=/usr/share/pixmaps
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ install -Dm644 desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ make DESTDIR=$pkgdir ICONDIR=/usr/share/pixmaps install
+ rm $pkgdir/usr/share/applications/kornelix-mystuff.desktop
+}