summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakub Klinkovský2015-07-27 12:14:56 +0200
committerJakub Klinkovský2015-07-27 12:14:56 +0200
commitf67ff35185daff9bb76a19b6a10f7ce43078e274 (patch)
tree37d211efbc5c0ad11c570d41ade4803aec4d420a /PKGBUILD
downloadaur-f67ff35185daff9bb76a19b6a10f7ce43078e274.tar.gz
initial commit (version 20150310-1)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3f3e8e597b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jakub Klinkovský <j.l.k@gmx.com>
+
+pkgname=mythes-cs
+pkgver=20150310
+pkgrel=1
+pkgdesc="Czech thesaurus"
+arch=("any")
+url="https://wiki.archlinux.org/index.php/LibreOffice#Language_Aids"
+license=("custom")
+optdepends=("libmythes: offers thesaurus library functions")
+source=("http://pkgs.fedoraproject.org/repo/pkgs/mythes-cs/thes_cs_CZ_v2.zip/7f9c85b104db4cc6a719b3aab8c69a10/thes_cs_CZ_v2.zip")
+md5sums=("7f9c85b104db4cc6a719b3aab8c69a10")
+
+package() {
+ cd "$srcdir"
+ install -dm755 "$pkgdir/usr/share/mythes"
+ install -m644 th_cs_CZ_v2.* "$pkgdir/usr/share/mythes"
+
+ # the symlinks
+ install -dm755 "$pkgdir/usr/share/myspell/dicts"
+ pushd "$pkgdir/usr/share/myspell/dicts"
+ for file in "$pkgdir/usr/share/mythes/"*; do
+ ln -sv /usr/share/mythes/$(basename $file) .
+ done
+ popd
+
+ # docs
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ install -m644 th_cs_CZ_license.txt "$pkgdir/usr/share/doc/$pkgname"
+}