summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavi da Silva Böger2015-08-07 13:51:47 -0300
committerDavi da Silva Böger2015-08-07 13:51:47 -0300
commit1c35678872f37cdcbfe7ef846402c89a68165118 (patch)
treead7f8aa099a033833d02ac5c6f3e2571d128d5b9 /PKGBUILD
downloadaur-1c35678872f37cdcbfe7ef846402c89a68165118.tar.gz
First commit to AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..226db9e0dc7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: AkiraYB <brunoyb!outlook,com>
+# Maintainer: Davi da Silva Böger <dsboger@gmail.com>
+
+pkgname=mythes-pt-br
+pkgver=20100528
+pkgrel=4
+pkgdesc='Portuguese (Brazil) thesaurus'
+arch=('any')
+url='http://extensions.services.openoffice.org/en/node/6213'
+license=('unknown')
+optdepends=('libmythes: offers thesaurus library functions')
+changelog="${pkgname}.changelog"
+source=('http://downloads.sourceforge.net/project/aoo-extensions/6212/0/dicsin-br.oxt')
+sha256sums=('0663f9ba720647499ef7d6960e5c7d3b2ee022cc47a933b121dbdbefd2abc2f4')
+
+package()
+{
+ cd "$srcdir"
+
+ local _mythesdir="${pkgdir}/usr/share/mythes"
+ local _dictsdir="${pkgdir}/usr/share/myspell/dicts"
+ local _docdir="${pkgdir}/usr/share/doc/${pkgname}"
+
+ install -d "$_mythesdir" "$_dictsdir" "$_docdir"
+
+ install -m 644 th_pt_BR.dat "${_mythesdir}/th_pt_BR_v2.dat"
+ install -m 644 th_pt_BR.idx "${_mythesdir}/th_pt_BR_v2.idx"
+
+ for _file in "$_mythesdir"/*
+ do
+ ln -sv "${_file#${pkgdir}}" "${_dictsdir}"
+ done
+
+ install -m 644 readme.txt "$_docdir"
+}