summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Bunton2023-04-10 10:05:09 +0100
committerJohn2023-04-10 10:06:54 +0100
commit420a1a42471d80daff3e0c0261adf9b99d5e372b (patch)
tree0c2dc9f5a3f4108e04f71baabe831d9dec625f2d /PKGBUILD
parent6f425be38ee6875e0be5e99fd631b8d9686d242d (diff)
downloadaur-420a1a42471d80daff3e0c0261adf9b99d5e372b.tar.gz
v32
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9962d9f48f6e..f0af79981821 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: dorphell <dorphell@archlinux.org>
pkgname=mythtv-git
-pkgver=31+fixes.20210401.563a05b7
+pkgver=32+fixes.20220310.ae60e830
pkgrel=1
pkgdesc="A Homebrew PVR project"
arch=('x86_64')
@@ -31,8 +31,10 @@ depends=(
'libxinerama'
'libxml2'
'libxrandr'
+ 'libzip'
'qt5-script'
'qt5-webkit'
+ 'soundtouch'
'taglib'
'x264'
'x265'
@@ -55,6 +57,7 @@ makedepends=(
'python-lxml'
'python-mysqlclient'
'python-requests'
+ 'python-setuptools'
'python-simplejson'
'yasm'
)
@@ -79,11 +82,10 @@ optdepends=(
conflicts=('myththemes' 'mythplugins-mythvideo' 'mythtv')
replaces=('myththemes' 'mythplugins-mythvideo' 'mythtv')
source=(
- "git+https://github.com/MythTV/mythtv#branch=fixes/31"
+ "git+https://github.com/MythTV/mythtv#branch=fixes/32"
'mythbackend.service'
'mythtv.desktop'
'mythtv.png'
- 'wayland-hide-mouse-cursor.patch'
'99-mythbackend.rules'
'sysusers.d'
)
@@ -92,19 +94,13 @@ sha256sums=(
'3c356d030c8e5fb8cbe7bc01041848c4e8073b0a696c0f34a3e3cc0fd83ecf0b'
'3fd2018d0d5aaa7d530835305dac80d4ca7d8fc991cdf9e1cebadebd86e25c03'
'12cb52bf9b084a4f16419c9370fef0450ce6a11308b0c3f7240f4f83df7e2ab6'
- 'bc43d38acac43bbc15dd6b27b74ff5a7e7abc16ad80ce6e676b108a2d501660c'
'ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333'
'470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae'
)
pkgver() {
cd "${srcdir}/mythtv/mythtv"
- echo -n "31+fixes.$(git show -s --format=%cd --date=short | tr -d -).$(git rev-parse --short=8 HEAD)"
-}
-
-prepare() {
- cd "${srcdir}/mythtv/mythtv"
- patch -Np2 < "${srcdir}/wayland-hide-mouse-cursor.patch"
+ echo -n "32+fixes.$(git show -s --format=%cd --date=short | tr -d -).$(git rev-parse --short=8 HEAD)"
}
build() {