summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAutumn Boyhan2022-12-29 10:06:17 -0500
committerAutumn Boyhan2022-12-29 10:06:17 -0500
commit460b9da44be6508fb536143c928d171d2cb3d490 (patch)
tree6873d64433c52262ec4623b89f7a6d98ccdef27f /PKGBUILD
parentdba45c58271517be6c77409eea4ddf91c50ad92d (diff)
downloadaur-460b9da44be6508fb536143c928d171d2cb3d490.tar.gz
Updated to version 0.5.0.
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a63ee3a1d396..cce49676f875 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
# Maintainer: Autumn Boyhan <autumn@crisismodel.com>
pkgname=naikari
-pkgver=0.4.1
+pkgver=0.5.0
pkgrel=1
-pkgdesc="A 2-D space trading and mercenary game forked from the Naev project."
+pkgdesc="2-D space trading and mercenary game forked from the Naev project."
arch=('x86_64')
url="https://naikari.github.io/"
license=('GPL3')
-depends=('sdl2_image' 'libxml2' 'freetype2' 'libpng' 'openal' 'libvorbis' 'libgl' 'luajit' 'suitesparse')
+depends=('sdl2_image' 'libxml2' 'freetype2' 'libpng' 'openal' 'libvorbis' 'libgl' 'luajit' 'suitesparse' 'libunibreak' 'physfs' 'glpk')
makedepends=('meson' 'ninja')
provides=('naikari')
conflicts=('naikari' 'naikari-git')
source=("https://github.com/naikari/naikari/releases/download/v${pkgver}/${pkgname}-${pkgver}-source.tar.xz")
-md5sums=('e5730d48ba79a9fd5622567d8e0b3faa')
+md5sums=('fc1de4b30be41c42392d66792d930288')
prepare() {
mv ${srcdir}/${pkgname}-${pkgver} ${srcdir}/${pkgname}
cd ${srcdir}/${pkgname}
- meson build --buildtype=release --prefix=/usr
- meson compile -C build
+ meson setup build .
+ cd build
+ meson configure --buildtype=release -Db_lto=true --prefix=/usr
+ meson compile
}
package() {