summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilken 'Akiko' Gottwalt2016-11-17 11:26:03 +0100
committerWilken 'Akiko' Gottwalt2016-11-17 11:26:03 +0100
commite148f8724af3999902c9e55a32cfe96c9b366d31 (patch)
tree264d6945630eede117a3940bcef0e34be1935d2b /PKGBUILD
parenta47ab8ff2165b6c3777b1feeb91e70cce86d1623 (diff)
downloadaur-e148f8724af3999902c9e55a32cfe96c9b366d31.tar.gz
Forced the use of Nanas own filesystem stuff instead of using Boost
or libc++ C++17 filesystem.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c21f09decc7..7e37e8f407bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nana
pkgver=1.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="An opensource cross-platform GUI library written in modern C++11 for static linking"
arch=("i686" "x86_64")
url="http://nanapro.org/en-us/"
@@ -25,7 +25,8 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DNANA_CMAKE_NANA_FILESYSTEM_FORCE=YES
make
}