summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoey Dumont2018-02-12 14:37:59 -0500
committerJoey Dumont2018-02-12 14:37:59 -0500
commit46c8f98d037503040dbca3f118d634872db7c429 (patch)
tree4008ca709ccb8a9a1c13010cbc5ca5e048266ac3 /PKGBUILD
parent38b2c542756e4f962e821afbb9613d23adbabc1a (diff)
downloadaur-46c8f98d037503040dbca3f118d634872db7c429.tar.gz
Minor changes.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d78c04ac8be..33b513de961c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Joey Dumont <joey.dumont@gmail.com>
pkgname=nano-git
-pkgver=20160530
+pkgver=20180208
pkgrel=1
pkgdesc="Pico editor clone with enhancements, git version"
arch=(i686 x86_64)
@@ -21,10 +21,11 @@ pkgver() {
git log -1 --format="%cd" --date=short | sed 's|-||g'
}
-build() {
- # Compiling nano.
+prepare() {
+ # Running the configure script.
cd $srcdir/nano
./autogen.sh
+
./configure \
--prefix=/usr \
--sysconfdir=/etc \
@@ -34,7 +35,11 @@ build() {
--bindir=/usr/bin \
--sbindir=/usr/bin \
--disable-wrapping-as-root
- make
+}
+
+build() {
+ cd $srcdir/nano
+ make
}
package(){