summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeo P2017-12-14 11:30:46 -0500
committerLeo P2017-12-14 11:30:46 -0500
commit99420cc04d46dca73d77a26a7b96a11d7dfecc74 (patch)
treea0bd5b767ce82aacb48040bbec40a19e089ad1d1 /PKGBUILD
downloadaur-99420cc04d46dca73d77a26a7b96a11d7dfecc74.tar.gz
first
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..163ba26675d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+pkgname=raiblocks-git
+pkgver=8.0.r123.g2db8063b
+pkgrel=1
+pkgdesc="RaiBlocks is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees."
+arch=('i686' 'x86_64')
+url="http://raiblocks.com/"
+license=('GPL')
+depends=('qt5' 'boost' 'boost-libs')
+provides=(raiblocks)
+pkgver() {
+ cd "raiblocks"
+ git describe --long --tags | sed 's/^[vV]//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+source=(git+https://github.com/clemahieu/raiblocks.git
+ git+https://github.com/boostorg/beast.git
+ git+https://github.com/weidai11/cryptopp.git
+ git+https://github.com/LMDB/lmdb.git
+ git+https://github.com/miniupnp/miniupnp.git
+ git+https://github.com/clemahieu/phc-winner-argon2.git)
+noextract=()
+md5sums=(SKIP
+ SKIP
+ SKIP
+ SKIP
+ SKIP
+ SKIP)
+
+prepare() {
+ cd "$srcdir/raiblocks"
+
+ git submodule init
+
+ git config submodule.beast.url $srcdir/beast
+ git config submodule.cryptopp.url $srcdir/cryptopp
+ git config submodule.lmdb.url $srcdir/lmdb
+ git config submodule.miniupnp.url $srcdir/miniupnp
+ git config submodule.phc-winner-argon2.url $srcdir/phc-winner-argon2
+
+ rm *.tar.gz || true 2>/dev/null
+
+ git submodule update
+ cmake cmake -D RAIBLOCKS_GUI=ON ./
+}
+
+build() {
+ cd "$srcdir/raiblocks"
+ make rai_wallet
+
+}
+
+package() {
+ cd "$srcdir/raiblocks"
+
+ install -Dm755 rai_wallet "$pkgdir"/usr/bin/rai_wallet
+ install -Dm755 rai_node "$pkgdir"/usr/bin/rai_node
+}
+
+# vim:set ts=2 sw=2 et: