summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2023-06-26 22:57:53 +0200
committerNarrat2023-06-26 22:57:53 +0200
commit587fecb007a7daec5cde82521720e7a64c2913aa (patch)
treebf517e0aec9a53b636ee8500c85d1316b67f0c7d /PKGBUILD
parent9428e7aafc52c249296288d2a5c44872256c23b4 (diff)
downloadaur-nanonote.tar.gz
nanonote: update to 1.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50186759bed9..49061eac112f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,21 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
-pkgname='nanonote'
-pkgver=1.3.0
-pkgrel=3
+pkgname=nanonote
+pkgver=1.4.0
+pkgrel=1
pkgdesc='Minimalist note taking application'
arch=('x86_64')
url='https://github.com/agateau/nanonote'
license=('BSD')
depends=('hicolor-icon-theme' 'qt5-base')
makedepends=('extra-cmake-modules' 'git' 'python-jinja' 'python-pyaml' 'qt5-tools')
-source=("git+${url}.git#tag=${pkgver}"
- "git+${url%/*}/qpropgen.git"
- "git+https://github.com/itay-grudev/SingleApplication.git")
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP')
+source=("git+${url}.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
prepare() {
cd "${pkgname}"
- # Submodule list: https://github.com/agateau/nanonote/raw/master/.gitmodules
git submodule init
- git config 'submodule.qpropgen.url' "${srcdir}/qpropgen"
- git config 'submodule.singleapplication.url' "${srcdir}/SingleApplication"
git submodule update
}