summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Bruguera2020-09-14 11:10:39 +0200
committerJoan Bruguera2020-09-14 11:10:39 +0200
commit397a8acba200aa13d5db57d98fed16d44a5c4b05 (patch)
tree76ec50b440d6054da355960bdae6988f0382c5f4 /PKGBUILD
parenta0d597f7839b09ad97644647fa5be52b873aadb3 (diff)
downloadaur-397a8acba200aa13d5db57d98fed16d44a5c4b05.tar.gz
Fix build due to deprecated glibc symbols.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 62d4e5b9d612..629dea0d451f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,21 @@ _bundlepkgname='ompss'
pkgdesc='Nanos++ is a runtime designed to serve as runtime support in parallel environments. It is mainly used to support OmpSs, a extension to OpenMP developed at BSC.'
pkgver='0.15.20190627'
_bundlepkgver='19.06'
-pkgrel='1'
+pkgrel='2'
arch=('i686' 'x86_64')
url='https://pm.bsc.es/ompss'
license=('GPL2')
depends=(extrae sqlite3)
makedepends=(python)
-source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_bundlepkgver}.tar.gz")
-sha512sums=(159efc17ba446f3f2205a8c0580ed10fab263f8bdb7306d5444d1fc6a592f80d749c03031e7e416090360c36a51a38da083b2b2ed4e75dda5c55a103806d91d2)
+source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_bundlepkgver}.tar.gz"
+ "nanox-Fix-build-due-to-use-of-deprecated-_sys_siglist.patch")
+sha512sums=(159efc17ba446f3f2205a8c0580ed10fab263f8bdb7306d5444d1fc6a592f80d749c03031e7e416090360c36a51a38da083b2b2ed4e75dda5c55a103806d91d2
+ f900d2c30236ef641e1e527364324e317d1df2746082df0e0bf8adcceb279b7cde6f0c094576e330de24fc9d51f989016f6e2d50489e308fe2f8683acb3bf41c)
prepare() {
cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-${pkgver%.*}"
+
+ patch -Np1 -i "$srcdir/nanox-Fix-build-due-to-use-of-deprecated-_sys_siglist.patch"
}
build() {