summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDrew DeVault2015-06-08 13:50:06 -0600
committerDrew DeVault2015-06-08 13:50:06 -0600
commit91bff138fc8572d2d7b1ce9497335fc1cbcdf511 (patch)
tree90b9daf3582fa3a0f1d091d2b59722c32e621621 /PKGBUILD
downloadaur-91bff138fc8572d2d7b1ce9497335fc1cbcdf511.tar.gz
Initial import from aur3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88bce7288a21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Contributor: Ali H. Caliskan <ali.h.caliskan AT gmail DOT com>
+# Contributor: Arjan Timmerman <arjan@soulfly.nl>
+# Contributor: Daniel 'maniel' Kaminski <maniel.rulez//gmail.com>
+
+# I know this PKGBUILD is stupid but it was abandoned and I just wanted to make it installable
+
+pkgname=nant
+pkgver=0.92
+pkgrel=6
+pkgdesc="A free .NET build tool, like make but without make's problems"
+arch=('i686' 'x86_64')
+url="http://nant.sourceforge.net"
+license="GPL"
+depends=('mono')
+makedepends=('pkgconfig')
+source=("http://downloads.sourceforge.net/nant/$pkgname-$pkgver-bin.tar.gz")
+md5sums=('1bcac3e7fab283240b78d21efa07f036')
+build() {
+ export MONO_SHARED_DIR=$srcdir/.wabi
+ mkdir -p "${MONO_SHARED_DIR}"
+}
+
+package() {
+ mkdir $pkgdir/usr $pkgdir/usr/share $pkgdir/usr/share/NAnt $pkgdir/usr/bin
+
+ cp -R $srcdir/$pkgname-$pkgver/* $pkgdir/usr/share/NAnt/
+ echo '/usr/bin/mono /usr/share/NAnt/bin/NAnt.exe "$@"' > $pkgdir/usr/bin/nant
+ chmod +x $pkgdir/usr/bin/nant
+}