summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLorenzo Gaifas2023-01-23 15:02:30 +0100
committerLorenzo Gaifas2023-01-23 15:02:30 +0100
commit16fa833a8f985f4bd8525cab22f5ad943c615024 (patch)
tree49e7c3eac288f976f7ab26c45a23f5725c489700 /PKGBUILD
parent1cf919f4ed32bc00329905622dfb4a72750897ed (diff)
downloadaur-16fa833a8f985f4bd8525cab22f5ad943c615024.tar.gz
v0.0.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9332b8dcae6a..93c24ce5b223 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,37 @@
_name='napari-console'
_author='napari'
pkgname="${_name}"
-pkgver=0.0.4
+pkgver=0.0.6
pkgrel=1
pkgdesc='A plugin that adds a console to napari.'
arch=('any')
url="https://github.com/${_author}/${_name}"
license=('BSD')
makedepends=(
+ 'python-build'
+ 'python-installer'
'python-setuptools-scm'
)
depends=(
+ 'ipython'
+ 'napari-plugin-engine'
'python'
'python-ipykernel'
- 'ipython'
'python-qtconsole'
'python-qtpy'
)
source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('ea0e30fbfdd76542adda44be457f1306a65146fe7578f95838e28d62874f4c45')
+sha256sums=('d3bbd3c25392ef0dabfaebc52d4866fc859b2d99e3dad9da4bc13f1a991cd500')
provides=("python-${_name}")
build() {
cd "${srcdir}/${_name}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"