summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLorenzo Gaifas2021-12-14 19:02:12 +0100
committerLorenzo Gaifas2021-12-14 19:02:12 +0100
commitf415a9b2414d3ecf6a8cee5654977a229646a85a (patch)
treeb652e247cc459ea78e33df99ebb80281aebcb05d /PKGBUILD
downloadaur-f415a9b2414d3ecf6a8cee5654977a229646a85a.tar.gz
first build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c135d977dd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Lorenzo Gaifas <brisvag at gmail dot com>
+
+_name='napari-svg'
+_author='napari'
+pkgname="${_name}"
+pkgver=0.1.5
+pkgrel=1
+pkgdesc='A plugin for writing svg files from napari.'
+arch=('any')
+url="https://github.com/${_author}/${_name}"
+license=('BSD')
+makedepends=(
+ 'python-setuptools-scm'
+)
+depends=(
+ 'python'
+ 'python-imageio'
+ 'python-napari-plugin-engine'
+ 'python-numpy'
+ 'python-vispy'
+)
+source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('7b0c9dfb66d63a251f550c074e1b11d177aaea7a61dd19fcdaed87739c441bfd')
+provides=("python-${_name}")
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+}
+
+# vim:set ts=2 sw=2 et:<Paste>