summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxpt2017-09-20 20:43:07 -0300
committerxpt2017-09-20 20:43:07 -0300
commitc1e340d091535728dd0af4cf14d4a9ceb7447d5a (patch)
treeaa204c0e8adf30c3b712d8eb4e682fb48295c416 /PKGBUILD
downloadaur-c1e340d091535728dd0af4cf14d4a9ceb7447d5a.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d874590a0fe7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: xpt <user.xpt@gmail.com>
+pkgname=nasc-git
+pkgver=0.4.5.r0.g5a22841
+pkgrel=1
+pkgdesc='Do maths like a normal person.'
+arch=('i686' 'x86_64')
+url='http://parnold-x.github.io/nasc/'
+license=('GPL3')
+depends=('gtk3' 'libqalculate' 'granite' 'glib2' 'libgee' 'gtksourceview3' 'libsoup')
+optdepends=()
+makedepends=('vala' 'git' 'cmake')
+provides=("nasc")
+conflicts=("nasc", "nasc-bzr")
+install="${pkgname%-*}.install"
+source=('git+https://github.com/parnold-x/nasc')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+
+}
+
+build() {
+ cd ${pkgname%-*}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd ${pkgname%-*}/build
+ make DESTDIR="${pkgdir}" install
+}
+