summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Goldsmith2021-01-05 23:27:20 -0500
committerAdam Goldsmith2021-01-05 23:27:20 -0500
commite88d01c04f0872a2f702172d7ca4199c4747ac26 (patch)
tree29582924edda2cca7477ea504d20384fecfb45eb /PKGBUILD
parent8850584ae3b470e990ee9c24d02bc9b6d3c2c278 (diff)
downloadaur-e88d01c04f0872a2f702172d7ca4199c4747ac26.tar.gz
Set CI=skip to force non-interactive install
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6bb133ca83da..11d3ec2ad275 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,6 +18,8 @@ sha512sums=('d51bc9916c106413ead36d3eb855fe8053e62fe3bc7a3500349f4209c7abe7c05ae
noextract=($pkgname-$pkgver.tgz)
package() {
+ # Pretend we are a continuous integration tool to force non-interactive install
+ export CI=skip
npm install -g --prefix "$pkgdir"/usr $pkgname-$pkgver.tgz
find "$pkgdir"/usr -type d -exec chmod 755 {} +
}