summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTiago Requeijo2017-10-17 13:51:48 -0400
committerTiago Requeijo2017-10-17 13:51:48 -0400
commite7e8627a2fceca1dd3a3c756b0496be14e9f6b48 (patch)
tree67e725df20c1032a3007248445916d47e8b750f0 /PKGBUILD
downloadaur-e7e8627a2fceca1dd3a3c756b0496be14e9f6b48.tar.gz
Initial commit, 3.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b881da5a54bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+_npmname=nativescript
+_npmver=3.2.1
+pkgname=nativescript-cli # All lowercase
+pkgver=3.2.1
+pkgrel=1
+pkgdesc="NativeScript CLI"
+arch=(any)
+url="https://www.npmjs.com/package/nativescript"
+license=('Apache 2.0')
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha256sums=(476e66c502869915a0f413b5fd8ea8b5b1520d2354d01b085920ae762ef228f4)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" "$srcdir"/$_npmname-$_npmver.tgz
+}