summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathan Lestrelin2017-11-06 14:50:16 +0100
committerJonathan Lestrelin2017-11-06 14:50:16 +0100
commitcb42e09d5fcd821d8c332fa85d3b97d5c2d8eed0 (patch)
tree9e6d3ff2e680a4f315135271df718e6fd18c2f37 /PKGBUILD
downloadaur-cb42e09d5fcd821d8c332fa85d3b97d5c2d8eed0.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db020aa9392b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jonathan Lestrelin <jonathan.lestrelin@gmail.com>
+pkgname=nautilus-search-by-image-git
+_pkgname=nautilus-search-by-image
+pkgver=r1.e60fa62
+pkgrel=1
+pkgdesc="Nautilus extension to do a reverse image search in Google from a local file (beware that this uploads images to transfer.sh and Google so use only if no privacy concerns)."
+arch=('any')
+url="https://github.com/jle64/nautilus-search-by-image"
+license=('GPL')
+depends=('python2-nautilus' 'python2-requests')
+makedepends=('git')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=('nautilus-search-by-image::git://github.com/jle64/nautilus-search-by-image.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p $pkgdir/usr/share/nautilus-python/extensions
+ cp google-image.py $pkgdir/usr/share/nautilus-python/extensions
+}