summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYoungjae Lee2022-01-21 17:02:31 +0900
committerYoungjae Lee2022-01-21 17:02:31 +0900
commit16b0410e236e000f23f3f648efc1e75aad299a49 (patch)
treeed2426f6385bd7d2d239cccc2134c3f5a7ce2fea /PKGBUILD
downloadaur-16b0410e236e000f23f3f648efc1e75aad299a49.tar.gz
Naver Whale v3.12.129.46
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d389077bdbf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Youngjae Lee <ls4154.lee@gmail.com>
+pkgname=naver-whale-stable
+pkgver=3.12.129.46
+pkgrel=1
+pkgdesc="The web browser from NAVER"
+arch=("x86_64")
+url="https://whale.naver.com"
+license=("custom")
+depends=(
+ 'alsa-lib'
+ 'gtk3'
+ 'libcups'
+ 'libxss'
+ 'libxtst'
+ 'nss'
+ 'ttf-liberation'
+ 'xdg-utils'
+)
+options=('!emptydirs' '!strip')
+source=("http://repo.whale.naver.com/stable/deb/pool/main/n/naver-whale-stable/naver-whale-stable_${pkgver}-1_amd64.deb"
+ "naver-whale-stable.sh"
+ "LICENSE.html")
+sha256sums=("1e242e0679cbcabf22a8f0b7697b20ef39dabd6856aeecc7d7af11d6b01abe32"
+ "11522689f4c94ea86bc7e50feb48c6b823cb3cdb7bb04b565a0db2f12d25d9a5"
+ "ed82f8f83c93cbd468395cc80e3be7beb8a3f18bdf5770f165c348c15f7e5e84")
+
+package() {
+ bsdtar -xf data.tar.xz -C "${pkgdir}/"
+
+ install -m755 naver-whale-stable.sh "${pkgdir}/usr/bin/naver-whale-stable"
+
+ install -Dm644 LICENSE.html "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.html"
+
+ for i in 16 24 32 48 64 128 256; do
+ install -Dm644 "${pkgdir}/opt/naver/whale/product_logo_${i}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/naver-whale.png"
+ done
+
+ rm -r "${pkgdir}/etc/cron.daily/" \
+ "${pkgdir}/opt/naver/whale/cron/" \
+ "${pkgdir}/opt/naver/whale"/product_logo_*.{png,xpm} \
+ "${pkgdir}/usr/share/menu/"
+}