summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMoses Narrow2019-12-10 15:02:40 -0600
committerMoses Narrow2019-12-10 15:02:40 -0600
commitd692a6617dab884fa13fbd266f9b44462d23c989 (patch)
treedaeeb5300bcaf0a293554fd7d922a57896bc27c5 /PKGBUILD
parent39f0cfdb9dde3b913b29699c42f49981a84d6236 (diff)
downloadaur-d692a6617dab884fa13fbd266f9b44462d23c989.tar.gz
update dependancies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 24 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e7a0fc907db..41b4a867c5cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@ pkgcaps=NBXplorer
pkgdesc="A minimalist UTXO tracker for HD Cryptocurrency Wallets."
pkgver='stable'
pkgpath="github.com/dgarage/${pkgname}"
-pkgrel=1
+pkgrel=3
arch=('any')
url="https://${pkgpath}"
license=(MIT)
-makedepends=('dotnet-sdk-bin')
-depends=('dotnet-sdk>=3.1.0')
+makedepends=()
+depends=('dotnet-host-bin' 'dotnet-runtime' 'dotnet-runtime-bin' 'dotnet-sdk' 'dotnet-sdk-bin' 'aspnet-runtime-2.1' 'aspnet-runtime-bin')
source=("${url}/archive/${pkgver}.tar.gz")
sha256sums=('SKIP')
@@ -18,8 +18,26 @@ mv ${srcdir}/${pkgcaps}-${pkgver} ${srcdir}/${pkgname}
cd ${srcdir}/${pkgname}
./build.sh
#set absolute path in run.sh
-echo -e '#!/bin/bash \n #launch nbxplorer \n dotnet run --no-launch-profile --no-build -c Release -p "/usr/lib/nbxplorer/NBXplorer/NBXplorer.csproj" -- $@' > run.sh
+echo -e '#!/bin/bash
+#launch nbxplorer
+dotnet run --no-launch-profile --no-build -c Release -p "/usr/lib/nbxplorer/NBXplorer/NBXplorer.csproj" -- $@
+' > run.sh
chmod +x run.sh
+
+echo -e '[Unit]
+Description=NBXplorer service
+After=network.target
+After=network-online.target
+After=bitcoind.service
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/nbxplorer
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target
+' > nbxplorer.service
}
package() {
@@ -27,6 +45,7 @@ package() {
mkdir -p ${pkgdir}/usr/bin/
mkdir -p ${pkgdir}/usr/lib/
mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}/
+mkdir -p ${pkgdir}/usr/lib/systemd/system/
#putting the sources in /usr/lib/nbxplorer
cp -r ${srcdir}/${pkgname}/ ${pkgdir}/usr/lib/
#symlinking run.sh to /usr/bin/nbxplorer
@@ -34,4 +53,5 @@ ln -rTsf $pkgdir/usr/lib/${pkgname}/run.sh ${pkgdir}/usr/bin/${pkgname}
chmod 755 ${pkgdir}/usr/bin/${pkgname}
#install the lisence
install -Dm644 ${pkgdir}/usr/lib/${pkgname}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+install -Dm644 ${pkgdir}/usr/lib/${pkgname}/nbxplorer.service ${pkgdir}/usr/lib/systemd/system/
}