summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMoses Narrow2019-12-17 13:50:07 -0600
committerMoses Narrow2019-12-17 13:50:07 -0600
commitfcba1398587d0243b295c0533bcfe791aa33fcd1 (patch)
tree0e0901fc616d221c50d7c59717ffe08fc5da6b02 /PKGBUILD
parentd692a6617dab884fa13fbd266f9b44462d23c989 (diff)
downloadaur-fcba1398587d0243b295c0533bcfe791aa33fcd1.tar.gz
add systemd service
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 7 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41b4a867c5cb..2b5ff7f6f78b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,17 @@ pkgrel=3
arch=('any')
url="https://${pkgpath}"
license=(MIT)
-makedepends=()
-depends=('dotnet-host-bin' 'dotnet-runtime' 'dotnet-runtime-bin' 'dotnet-sdk' 'dotnet-sdk-bin' 'aspnet-runtime-2.1' 'aspnet-runtime-bin')
-source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=('SKIP')
+makedepends=('dotnet-host-bin' 'dotnet-runtime' 'dotnet-runtime-bin' 'dotnet-sdk' 'dotnet-sdk-bin' 'aspnet-runtime-2.1' 'aspnet-runtime-bin')
+depends=(${makedepends} 'bitcoin-daemon')
+source=("${url}/archive/${pkgver}.tar.gz"
+"nbxplorer.service")
+sha256sums=('SKIP'
+ '198e6e0ba127402b549c88b2748f80026a511b9b956291803a64355571d859dd')
build() {
mv ${srcdir}/${pkgcaps}-${pkgver} ${srcdir}/${pkgname}
cd ${srcdir}/${pkgname}
+cp -b ../nbxplorer.service nbxplorer.service
./build.sh
#set absolute path in run.sh
echo -e '#!/bin/bash
@@ -23,21 +26,6 @@ echo -e '#!/bin/bash
dotnet run --no-launch-profile --no-build -c Release -p "/usr/lib/nbxplorer/NBXplorer/NBXplorer.csproj" -- $@
' > run.sh
chmod +x run.sh
-
-echo -e '[Unit]
-Description=NBXplorer service
-After=network.target
-After=network-online.target
-After=bitcoind.service
-
-[Service]
-Type=oneshot
-ExecStart=/usr/bin/nbxplorer
-RemainAfterExit=yes
-
-[Install]
-WantedBy=multi-user.target
-' > nbxplorer.service
}
package() {