summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHaruue Icymoon2019-04-01 14:31:22 +0800
committerHaruue Icymoon2019-04-01 14:31:22 +0800
commit82b4b95d17793290ba2fef5f3f10d0740fc2f832 (patch)
tree0d983e76b65ed866bdac0296fbdf45adc2b9aa7e /PKGBUILD
downloadaur-82b4b95d17793290ba2fef5f3f10d0740fc2f832.tar.gz
init: add package ncmdump-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5af7999eaeb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Haruue Icymoon <haruue@caoyue.com.cn>
+
+pkgname=ncmdump-git
+_basename="${pkgname%-git}"
+pkgver=r20.ee3bdb4
+pkgrel=1
+pkgdesc='netease cloud music copyright protection file dump'
+arch=('i686' 'x86_64')
+url='https://github.com/anonymous5l/ncmdump'
+conflicts=("$_basename")
+provides=("$_basename")
+license=('unknown')
+depends=('taglib')
+source=("$_basename"::'git+https://github.com/anonymous5l/ncmdump')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_basename"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_basename"
+ make
+}
+
+package() {
+ install -Dm755 "$srcdir/$_basename/$_basename" "$pkgdir/usr/bin/$_basename"
+}
+
+# vim:set ts=8 sts=2 sw=2 et: