summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHurricanePootis2022-07-25 17:15:26 -0500
committerHurricanePootis2022-07-25 17:15:26 -0500
commitaa14c3c27b63a42a079d728af1eb941785e70ade (patch)
treeaea7734c05530fc73a46187cdfea99ee3281fac3 /PKGBUILD
parent2f47001970b7d0583952ddf2bee47dbad63c0f4c (diff)
downloadaur-aa14c3c27b63a42a079d728af1eb941785e70ade.tar.gz
Enable building of tools
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 017b7d3f0ad8..f917a5293b96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=ncnn-git
_pkgname=ncnn
-pkgver=20220721.r2.g13a953398
+pkgver=20220721.r5.g4158e6366
pkgrel=1
pkgdesc="High-performance neural network inference framework optimized for the mobile platform"
url="https://github.com/Tencent/ncnn"
@@ -29,13 +29,10 @@ prepare() {
cd "${srcdir}/ncnn"
# init submodules
- git submodule init glslang
git config submodule.glslang.url "$srcdir/glslang"
- git submodule update
-
- git submodule init python/pybind11
git config submodule.python/pybind11.url "$srcdir/pybind11"
- git submodule update
+
+ git submodule update --init
}
build() {
@@ -48,12 +45,15 @@ build() {
fi
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_BUILD_TYPE='Release' \
-DNCNN_BUILD_EXAMPLES=OFF \
-DNCNN_VULKAN=ON \
-DNCNN_SYSTEM_GLSLANG=ON \
-DNCNN_SHARED_LIB=ON \
-DNCNN_ENABLE_LTO=ON \
+ -DNCNN_STDIO=ON \
+ -DNCNN_STRING=ON \
+ -DNCNN_BUILD_TOOLS=1 \
-DGLSLANG_TARGET_DIR=/usr/lib/cmake \
-Wno-dev \
..