summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHurricanePootis2024-04-01 22:31:11 -0500
committerHurricanePootis2024-04-01 22:31:11 -0500
commite287d83320631c44b91b48b8cf2e74c805522522 (patch)
tree82e807e3f0c2ad8765d666e7b924392a68f0de5c /PKGBUILD
parenta7fd985ad64a217da1902a58903843c519c25062 (diff)
downloadaur-e287d83320631c44b91b48b8cf2e74c805522522.tar.gz
Make license more accurate and fix package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3d27a36a174..5dffd250d83b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=ncnn-git
_pkgname=ncnn
-pkgver=20231027.r9.g31e315981
+pkgver=20240102.r68.g824b79a31
pkgrel=1
pkgdesc="High-performance neural network inference framework optimized for the mobile platform"
url="https://github.com/Tencent/ncnn"
-license=('BSD')
-depends=('glslang')
+license=('BSD-3-Clause' 'BSD-2-Clause' 'Zlib')
+depends=('glibc')
makedepends=('git' 'cmake' 'vulkan-icd-loader' 'protobuf' 'vulkan-headers')
optdepends=('protobuf: for onnx2ncnn')
conflicts=('ncnn')
@@ -42,13 +42,12 @@ build() {
-DCMAKE_BUILD_TYPE='Release' \
-DNCNN_BUILD_EXAMPLES=OFF \
-DNCNN_VULKAN=ON \
- -DNCNN_SYSTEM_GLSLANG=ON \
+ -DNCNN_SYSTEM_GLSLANG=OFF \
-DNCNN_SHARED_LIB=ON \
-DNCNN_ENABLE_LTO=ON \
-DNCNN_STDIO=ON \
-DNCNN_STRING=ON \
-DNCNN_BUILD_TOOLS=1 \
- -DGLSLANG_TARGET_DIR=/usr/lib/cmake \
-Wno-dev
cmake --build build
}