summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Hofmann2021-03-17 13:31:28 +0100
committerPeter Hofmann2021-03-17 13:31:28 +0100
commit4786c6bd441a3892e03e5316c10827d7be2d75b9 (patch)
tree698f35cfc55be2311e1118fe896cd12dfad375c2 /PKGBUILD
parent3bbbb32360b17f76174871d8ddde86381332ead7 (diff)
downloadaur-4786c6bd441a3892e03e5316c10827d7be2d75b9.tar.gz
Revert "Add blunt workaround for building with GCC 10"
This reverts commit 8e57546ba0b0d0ac94505b840b089a15bd657f92. Upstream handles this now.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c0d1c86aadc..546fb1d5772e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=ncsa-mosaic-git
epoch=1
pkgver=2.7b6.r25.af942b9
_pkgver=2.7b6
-pkgrel=3
+pkgrel=2
pkgdesc="One of the first graphical web browsers"
url="https://github.com/yotann/ncsa-mosaic"
license=('custom')
@@ -19,20 +19,14 @@ makedepends=('git')
provides=("${pkgname%-git}" 'mosaic')
conflicts=("${pkgname%-git}" 'mosaic')
options=(!makeflags)
-source=('git+https://github.com/yotann/ncsa-mosaic.git' fcommon.patch)
-sha256sums=('SKIP'
- 'a228a1cd0f0a30362b198c53fb2d54264e9aff9932544dd6ace7fb0607bfbc29')
+source=('git+https://github.com/yotann/ncsa-mosaic.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "$_pkgver.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$srcdir/${pkgname%-git}"
- patch -p1 <"$srcdir"/fcommon.patch
-}
-
build() {
cd "$srcdir/${pkgname%-git}"
make linux