summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEden Rose2017-09-11 18:25:56 -0400
committerEden Rose2017-09-11 18:25:56 -0400
commitc25e5aec3069e524a2c213502a6224f47f42a164 (patch)
tree19939fbee44209a6652e7020a5bbab8f6cdf7916 /PKGBUILD
downloadaur-c25e5aec3069e524a2c213502a6224f47f42a164.tar.gz
Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD74
1 files changed, 74 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6a1f6090cca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# $Id$
+# Maintainer: Eden Rose(endlesseden) <eenov1988 "at" gmail.com >
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
+_pkgname=ncurses
+pkgname=ncurses-full-git
+_pkgver=6.0-20170902
+pkgver=${_pkgver/-/+}
+pkgrel=1
+pkgdesc='System V Release 4.0 curses emulation library, with static and shared libraries, Inclusion of libTinfo.'
+arch=(i686 x86_64)
+url='http://invisible-island.net/ncurses/ncurses.html'
+license=(MIT)
+depends=(glibc gcc-libs)
+provides=(libncurses++w.a libformw.a libmenuw.a libpanelw.a libncursesw.a libncurses++w.so libformw.so libmenuw.so
+libpanelw.so libncursesw.so libtinfo.a libtinfo.so ncurses ncurses-full libtinfo)
+conflicts=(libtinfo ncurses ncurses-full ncurses5-compat-libs)
+source=(ncurses::git+https://github.com/mirror/ncurses.git)
+md5sums=('SKIP')
+
+_pkgver() {
+cd $srcdir/$_pkgname
+VER="$(git log -1 --decorate=short | grep ncurses | sed -e 's/ /\n/g' | tail -4 | head -1)"
+PATCH="$(git log -1 --decorate=short | grep ncurses | sed -e 's/ /\n/g' | tail -1 | head -1)"
+echo -n $VER+$PATCH
+}
+
+
+build() {
+ cd $_pkgname
+
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --with-pkg-config-libdir=/usr/lib/pkgconfig \
+ --with-static --with-normal --without-debug --without-ada \
+ --enable-widec --enable-pc-files --with-cxx-binding --with-cxx-static \
+ --with-shared --with-cxx-shared
+
+ make
+}
+
+package() {
+
+ cd $_pkgname
+ make DESTDIR="$pkgdir" install
+
+ # fool packages looking to link to non-wide-character ncurses libraries
+ for lib in ncurses ncurses++ form panel menu; do
+ echo "INPUT(-l${lib}w)" > "$pkgdir/usr/lib/lib${lib}.a"
+ echo "INPUT(-l${lib}w)" > "$pkgdir/usr/lib/lib${lib}.so"
+ ln -s ${lib}w.pc "$pkgdir/usr/lib/pkgconfig/${lib}.pc"
+ done
+
+ # some packages look for -lcurses during build
+ echo "INPUT(-lncursesw)" > "$pkgdir/usr/lib/libcursesw.a"
+ ln -s libncurses.a "$pkgdir/usr/lib/libcurses.a"
+
+ echo "INPUT(-lncursesw)" > "$pkgdir/usr/lib/libcursesw.so"
+ ln -s libncurses.so "$pkgdir/usr/lib/libcurses.so"
+
+ # install license, rip it from the readme
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ grep -B 100 '$Id' README > "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # install libtinfo
+ install -d "$pkgdir"/usr/lib
+ ln -s /usr/lib/libncursesw.so.$pkgver "$pkgdir"/usr/lib/libtinfo.so."$pkgver"
+ ln -s /usr/lib/libtinfo.so."$pkgver" "$pkgdir"/usr/lib/libtinfo.so
+ ln -s /usr/lib/libncursesw.a.$pkgver "$pkgdir"/usr/lib/libtinfo.a."$pkgver"
+ ln -s /usr/lib/libtinfo.a."$pkgver" "$pkgdir"/usr/lib/libtinfo.a
+
+}
+