summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFederico Di Pierro2016-05-06 16:52:44 +0200
committerFederico Di Pierro2016-05-06 16:52:44 +0200
commit9287d02e1a264aa565f9d062188991ec81463c31 (patch)
treeaeefc2898a016bca601841f77c8655df8e5f62d5 /PKGBUILD
parente1f5b217150589b9944d13d1e65a8242143f3214 (diff)
downloadaur-9287d02e1a264aa565f9d062188991ec81463c31.tar.gz
updated package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--[l---------]PKGBUILD43
1 files changed, 42 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8676560cb999..b5c7c99d1b98 120000..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1 +1,42 @@
-/home/federico/Progetti/ncursesFM/Arch/PKGBUILD \ No newline at end of file
+# Maintainer: Federico Di Pierro <nierro92@gmail.com>
+
+pkgname=ncursesfm-git
+_gitname=ncursesFM
+pkgver=0.r416.4ea8b90
+pkgrel=2
+pkgdesc="A FileManager written in c and ncurses library."
+arch=('i686' 'x86_64')
+url="https://github.com/FedeDP/${_gitname}"
+license=('GPL')
+depends=('ncurses' 'libconfig' 'libarchive' 'glibc' 'libcups' 'libx11' 'systemd')
+optdepends=('xdg-utils: xdg-open support'
+ 'udisks2: mountable drives and ISO mount support'
+ 'packagekit: package installation support'
+ 'upower: AC (dis)connection events support')
+# libcups, libconfig and libx11 are optional build dep.
+# If compiled without them, the program will run just fine;
+# but that would disable xdg-open, config file read and printing support.
+# systemd too is an optdep. But in arch libudev is packaged together with it,
+# and libudev is a mandatory dep.
+makedepends=('git')
+source=("git://github.com/FedeDP/${_gitname}.git")
+backup=('etc/default/ncursesFM.conf')
+install=ncursesFM.install
+sha256sums=("SKIP")
+
+pkgver() {
+ cd $_gitname
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build()
+{
+ cd $srcdir/$_gitname
+ make ncursesFM
+ make clean
+}
+
+package() {
+ cd $srcdir/$_gitname
+ make DESTDIR="$pkgdir" install
+}