summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFilippo Berto2020-08-05 19:36:27 +0200
committerFilippo Berto2020-08-05 19:36:27 +0200
commita34496b7ceceff3fba42d6f8d707ba12422e43c4 (patch)
tree00d3dd2de117a3e00a2a5432209f741ed4926bd6 /PKGBUILD
parentea7b0691f9e7c15f5280eaab7907bffe8f7835dc (diff)
downloadaur-a34496b7ceceff3fba42d6f8d707ba12422e43c4.tar.gz
Add tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88d3c3e19209..8363c3c2913e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=psync
pkgname=ndn-${_pkgname}-git
pkgver=0.2.0.r8.g042dfb3
-pkgrel=2
+pkgrel=3
# epoch=
pkgdesc="Library implementing Named Data Networking (NDN) primitives that can be used to write various NDN applications"
arch=('i686' 'x86_64')
@@ -31,7 +31,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- ./waf configure --prefix=/usr
+ ./waf configure --prefix=/usr --with-tests
}
build() {
@@ -39,6 +39,11 @@ build() {
./waf build
}
+check() {
+ cd "${srcdir}/${_pkgname}"
+ ./build/unit-tests
+}
+
package() {
cd "${srcdir}/${_pkgname}"
./waf install --destdir="${pkgdir}"