summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302020-01-22 19:53:45 +0100
committerM0Rf302020-01-22 19:53:45 +0100
commit73417c5a949f3e24cb13a703a798f171fb7f66a7 (patch)
treeb70fb9ca9769d489362bc69830ecdf3000264a4e /PKGBUILD
parenta0bc6c360199fd74b2cd20bc0d0dabdcc8834661 (diff)
downloadaur-73417c5a949f3e24cb13a703a798f171fb7f66a7.tar.gz
ndpi: 3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32d872f54d27..051f3ce2c41d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: robertfoster
pkgname=ndpi
-pkgver=2.8
+pkgver=3.0
pkgrel=1
pkgdesc="Open and Extensible GPLv3 Deep Packet Inspection Library"
arch=('i686' 'x86_64')
@@ -13,18 +13,15 @@ source=("https://github.com/ntop/nDPI/archive/$pkgver.tar.gz")
build() {
cd ${srcdir}/nDPI-$pkgver
- # Remove hardcoded path
- sed -i "s|\/usr\/local|\/usr\/|g" src/lib/Makefile.in example/Makefile.in
- sed -i "s|libdata|lib|g" Makefile.am
./autogen.sh
- ./configure --prefix=/usr --with-pic --includedir=/usr/include --libdir=/usr/lib
+ ./configure --prefix=/usr --with-pic --includedir=/usr/include --libdir=/usr/lib
make
}
package() {
cd ${srcdir}/nDPI-$pkgver
make DESTDIR="${pkgdir}" install
- ln -sr "/usr/include/$pkgname" "$pkgdir/usr/include/lib$pkgname"
+ rm -rf "${pkgdir}/usr/sbin"
}
-md5sums=('99721d8ecb9b8e487047a7777df86403')
+md5sums=('e1df6041ca61e78284254e183741f51d')