summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGianluca Boiano2018-10-23 14:14:44 +0200
committerGianluca Boiano2018-10-23 14:14:44 +0200
commit786d83d4b844f0354568893f74583eed7d1645d7 (patch)
tree5bc6c6e4e02a0c3cbff5d6cf147e23212bb3cd53 /PKGBUILD
parent2fa43015fe3a3aedf96f96e77ce85d7fb313d002 (diff)
downloadaur-786d83d4b844f0354568893f74583eed7d1645d7.tar.gz
ndpi: fixed packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 427368085593..d44210030b35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,19 @@
pkgname=ndpi
pkgver=2.4
-pkgrel=1
+pkgrel=2
pkgdesc="Open and Extensible GPLv3 Deep Packet Inspection Library"
arch=('i686' 'x86_64')
url="http://www.ntop.org/products/ndpi/"
license=('GPL3')
conflicts=('ndpi-svn')
-options=('staticlibs')
-source=("https://github.com/ntop/nDPI/archive/$pkgver.tar.gz")
+options=('staticlibs' '!strip')
+source=("https://github.com/ntop/nDPI/archive/$pkgver.tar.gz"
+ make-patch)
build() {
cd ${srcdir}/nDPI-$pkgver
+ patch -Np1 -i ../make-patch
./autogen.sh
./configure --prefix=/usr --with-pic --includedir=/usr/include --libdir=/usr/lib
make
@@ -20,10 +22,8 @@ build() {
package() {
cd ${srcdir}/nDPI-$pkgver
- make DESTDIR="${pkgdir}/" install
- mv $pkgdir/usr/include/libndpi-${pkgver}*/libndpi $pkgdir/usr/include
- rm -r $pkgdir/usr/include/libndpi-${pkgver}*
- sed -i 's|\/libndpi-2.0.0||g' $pkgdir/usr/lib/pkgconfig/libndpi.pc
+ make DESTDIR="${pkgdir}" install
}
-md5sums=('110478950391bbe8b25201c6a09e2516')
+md5sums=('110478950391bbe8b25201c6a09e2516'
+ '5b359b62300accf27087060a853f04c8')