summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-07 12:10:54 +0100
committerGianluca Boiano2021-02-07 12:10:54 +0100
commitac6cccb5d8262ca39c8a2f3dee976ff25cdffc14 (patch)
tree339a43f90f4e7f7494b2e20817c302cbbf6e60f1 /PKGBUILD
parent39149de748fa47b1fa7f20c76d9a916b1ac5cc12 (diff)
downloadaur-ac6cccb5d8262ca39c8a2f3dee976ff25cdffc14.tar.gz
ndpi: don't use -D_FORTIFY_SOURCE=2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32e46bd0ca5c..e1ca187a528a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,26 @@
pkgname=ndpi
pkgver=3.4
-pkgrel=1
+pkgrel=2
pkgdesc="Open and Extensible GPLv3 Deep Packet Inspection Library"
arch=('i686' 'x86_64')
url="http://www.ntop.org/products/ndpi/"
license=('GPL3')
conflicts=('ndpi-svn')
options=()
-source=("https://github.com/ntop/nDPI/archive/$pkgver.tar.gz")
+source=("https://github.com/ntop/nDPI/archive/${pkgver}.tar.gz")
build() {
- cd ${srcdir}/nDPI-$pkgver
- ./autogen.sh
- ./configure --prefix=/usr --with-pic --includedir=/usr/include --libdir=/usr/lib
- make
+ cd "${srcdir}/nDPI-${pkgver}"
+ unset CPPFLAGS
+ ./autogen.sh
+ ./configure --prefix=/usr --with-pic --includedir=/usr/include --libdir=/usr/lib
+ make
}
package() {
- cd ${srcdir}/nDPI-$pkgver
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/nDPI-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}
md5sums=('4a2978b0d527a220ab46344444a1934c')