summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryochananmarqos2019-04-29 09:21:26 -0600
committeryochananmarqos2019-04-29 09:21:26 -0600
commit319c3b420004269a74e6c4cc65ff15dc74c4794b (patch)
tree3c2777d136554af6d442c4324715e2443c96e8ab /PKGBUILD
parenta16f77e31f3f88f7d8e07c0969cf8fd70091cf2a (diff)
downloadaur-319c3b420004269a74e6c4cc65ff15dc74c4794b.tar.gz
PKGBUILD tweaks
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0d1af154ac8..5625382af39d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
pkgname=nemo-deja-dup-git
-_gitname=nemo-actions
pkgver=r2.f99427f
pkgrel=4
pkgdesc="Déjà Dup Actions for Nemo File Manager"
arch=('any')
-url="https://github.com/erickj/$_gitname"
+url="https://github.com/erickj/nemo-actions"
license=('GPL')
depends=('nemo' 'deja-dup')
-source=("git+https://github.com/erickj/$_gitname.git")
-md5sums=('SKIP')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/erickj/nemo-actions.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/nemo-actions"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/nemo-actions"
install -Dm755 deja-dup_restore-missing.nemo_action "$pkgdir/usr/share/nemo/actions/deja-dup_restore-missing.nemo_action"
install -Dm755 deja-dup_revert.nemo_action "$pkgdir/usr/share/nemo/actions/deja-dup_revert.nemo_action"
}