summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Brodsky2018-11-04 23:29:54 +0000
committerKevin Brodsky2018-11-04 23:33:25 +0000
commite35b6feffad071c37fb539c289e6385661b4530a (patch)
treecc0ac32279590fd8f67f2805a2a517944f576c07 /PKGBUILD
parentaca39ffef124075af700a6ea19c4dc911a3ef0aa (diff)
downloadaur-e35b6feffad071c37fb539c289e6385661b4530a.tar.gz
updpkg: 0.3-5 (move to Python 3)
nemo-python now uses Python 3, and for now the Python 3 version of nemo-mediainfo-tab lives in a separate branch, see: https://github.com/linux-man/nemo-mediainfo-tab/issues/7 On the plus side, it means we don't need to change the script's interpreter any more. While at it, quote some paths, in case someone feels adventurous and builds from a path with spaces :)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f5ba987dd32..647bc77a2a1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,18 @@
# Co-Maintainer: Corax
pkgname=nemo-mediainfo-tab
pkgver=0.3
-pkgrel=4
+_pkgver=${pkgver}-python3
+pkgrel=5
pkgdesc="View media information from the properties tab"
arch=('any')
url="https://github.com/linux-man/nemo-mediainfo-tab"
license=('GPL3')
-depends=('python2-mediainfodll' 'nemo-python')
+depends=('python-mediainfodll' 'nemo-python')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-md5sums=('20840b51231033c903c779e8f4b39ddd')
-
-prepare() {
- sed -i 's,/usr/bin/python,/usr/bin/python2,' ${pkgname}-${pkgver}/nemo-extension/${pkgname}.py
-}
+md5sums=('6723405faaed04aec1c930fc74fcf099')
package() {
- install -Dm644 ${pkgname}-${pkgver}/nemo-extension/${pkgname}.py ${pkgdir}/usr/share/nemo-python/extensions/${pkgname}.py
- mkdir ${pkgdir}/usr/share/nemo-python/extensions/${pkgname}
- cp -a ${pkgname}-${pkgver}/nemo-extension/${pkgname}/locale/. ${pkgdir}/usr/share/nemo-python/extensions/${pkgname}/locale
+ install -Dm644 "${pkgname}-${_pkgver}/nemo-extension/${pkgname}.py" "${pkgdir}/usr/share/nemo-python/extensions/${pkgname}.py"
+ mkdir "${pkgdir}/usr/share/nemo-python/extensions/${pkgname}"
+ cp -a "${pkgname}-${_pkgver}/nemo-extension/${pkgname}/locale" "${pkgdir}/usr/share/nemo-python/extensions/${pkgname}/locale"
}