summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkatoitalia2021-12-16 10:51:12 +0100
committerkatoitalia2021-12-16 10:51:12 +0100
commitb09e82a09bd71a2c27cdc20be535b117493739a3 (patch)
treea44aa480822dad2f5f6d7aad00d5f9f3fa3747d7 /PKGBUILD
parent9089bbff87c6cb1893d7048ead68653778fa3350 (diff)
downloadaur-b09e82a09bd71a2c27cdc20be535b117493739a3.tar.gz
added ncurses as dep, more compliant PKGBUILD now works even in corner cases
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a134184cbea1..3f8bfa33f765 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,31 @@
# Maintainer: katoitalia
pkgname=neo-matrix-git
-pkgver=r19.31391fd
-pkgrel=2
+pkgver=r20.28cddfa
+pkgrel=3
pkgdesc='Simulates the digital rain from "The Matrix" (cmatrix clone with 32-bit color and Unicode support)'
-arch=('any')
+arch=(x86_64 i686 i486 pentium4 arm armv6h armv7h aarch64)
url='https://github.com/st3w/neo'
license=('GPL3')
+depends=('ncurses' 'ttf-hanazono')
makedepends=('git' 'autoconf-archive')
-depends=('ttf-hanazono')
-provides=('neo-matrix-git')
+provides=('neo-matrix')
+conflicts=('neo-matrix')
source=("git+https://github.com/st3w/neo.git")
md5sums=('SKIP')
-options=(!strip)
pkgver() {
cd "${srcdir}/neo"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
+prepare() {
cd "${srcdir}/neo"
./autogen.sh
+}
+
+build() {
+ cd "${srcdir}/neo"
./configure
make
}