summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2021-11-26 01:05:20 +0100
committerhaawda2021-11-26 01:05:20 +0100
commitc23b36729152334583ce42ce0af59957801aa4bc (patch)
treeec441818afb0573d7b30b115ffbcc1924d96536e /PKGBUILD
parent53e015ce794e166f7084b00999eeca164c978925 (diff)
downloadaur-c23b36729152334583ce42ce0af59957801aa4bc.tar.gz
add prepare function to actually apply the patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05043126d9ec..ec93b017a705 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,6 +21,11 @@ pkgver() {
git describe --tags | sed 's+-+.r+' |tr - . | cut -c2-
}
+prepare() {
+ cd ${pkgname%-git}
+ git apply "$srcdir"/io-curses.patch
+}
+
build() {
cd ${pkgname%-git}
autoreconf -iv