summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpeeweep2020-06-30 01:54:37 +0000
committerpeeweep2020-06-30 09:54:37 +0800
commit177c761257d3ba70bf77cc3c6598ab2d5f6a67a4 (patch)
treea4498e1064fa27181a2f5017706534e77b621b44 /PKGBUILD
parentde39d4008bee88ce1a6b36743027bc33d4ca9517 (diff)
downloadaur-177c761257d3ba70bf77cc3c6598ab2d5f6a67a4.tar.gz
fix patch hunk
Signed-off-by: peeweep <peeweep@0x0.ee>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7fc0fd8c2440..b0ded097531d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=neovide
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc='No Nonsense Neovim Client in Rust'
arch=('x86_64')
url='https://github.com/Kethku/neovide'
@@ -12,13 +12,13 @@ makedepends=('rust' 'gtk3' 'cmake' 'sdl2' 'make')
provides=("neovide")
conflicts=("neovide-git")
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
- "0001-Remove-unnecessary-braces-around-if-condition.patch::https://github.com/Kethku/neovide/commit/c4890065a33ac265184400ab83743702efbaf291.patch")
+ "0001-Remove-unnecessary-braces-around-if-condition.patch")
sha256sums=('4daaad6ff527c299b9fa3db677bc1320b9596efbc27853ed730a57df6c1568fd'
- 'cfd5f5fa8015b377153d60515f2d797b9241d8df60633cfd85c9a24204541d9b')
+ 'aa9a7032a38f14c445e343c672e87b8128625f87132461c87cae42377e34841c')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 < "${srcdir}/0001-Remove-unnecessary-braces-around-if-condition.patch"
+ patch -t -p1 < "${srcdir}/0001-Remove-unnecessary-braces-around-if-condition.patch"
sed -i 's/debug = true/opt-level = 3\ndebug = false/' Cargo.toml
sed -i 's/Icon=neovide/Icon=nvim/' assets/neovide.desktop
}