summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Yang2020-06-30 19:46:32 +0800
committerAntonio Yang2020-06-30 19:46:32 +0800
commit2ceb798b76a68ea653742633f71bed4208008b89 (patch)
tree2471069dd7a7116f1b22118aa98862efe1418693 /PKGBUILD
parent72f24d6494bb42df93bbc58fd2218d782f42992f (diff)
downloadaur-2ceb798b76a68ea653742633f71bed4208008b89.tar.gz
rm patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a7b1cec5479..aebda5bb3807 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: peeweep <peeweep at 0x0 dot ee>
+# Co-Maintainer: Antonio Yang <yanganto@gmail.com>
pkgname=neovide
pkgver=0.6.0
-pkgrel=3
+pkgrel=4
pkgdesc='No Nonsense Neovim Client in Rust'
arch=('x86_64')
url='https://github.com/Kethku/neovide'
@@ -11,14 +12,11 @@ depends=('neovim' 'fontconfig' 'freetype2' 'libglvnd' 'sndio')
makedepends=('rust' 'gtk3' 'cmake' 'sdl2' 'make')
provides=("neovide")
conflicts=("neovide-git")
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
- "0001-Remove-unnecessary-braces-around-if-condition.patch::https://github.com/Kethku/neovide/commit/c4890065a33ac265184400ab83743702efbaf291.patch")
-sha256sums=('4daaad6ff527c299b9fa3db677bc1320b9596efbc27853ed730a57df6c1568fd'
- 'cfd5f5fa8015b377153d60515f2d797b9241d8df60633cfd85c9a24204541d9b')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('4daaad6ff527c299b9fa3db677bc1320b9596efbc27853ed730a57df6c1568fd')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -c -p1 < "${srcdir}/0001-Remove-unnecessary-braces-around-if-condition.patch"
sed -i 's/debug = true/opt-level = 3\ndebug = false/' Cargo.toml
sed -i 's/Icon=neovide/Icon=nvim/' assets/neovide.desktop
}