summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpeeweep2020-06-30 02:36:04 +0000
committerpeeweep2020-06-30 10:36:04 +0800
commit72f24d6494bb42df93bbc58fd2218d782f42992f (patch)
tree88c99741c0d37d27e7a8cdb64a1d3cc2e7fa6a0a /PKGBUILD
parent177c761257d3ba70bf77cc3c6598ab2d5f6a67a4 (diff)
downloadaur-72f24d6494bb42df93bbc58fd2218d782f42992f.tar.gz
use patch -c option skip hunk failed patch
Signed-off-by: peeweep <peeweep@0x0.ee>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0ded097531d..1a7b1cec5479 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=neovide
pkgver=0.6.0
-pkgrel=2
+pkgrel=3
pkgdesc='No Nonsense Neovim Client in Rust'
arch=('x86_64')
url='https://github.com/Kethku/neovide'
@@ -12,13 +12,13 @@ makedepends=('rust' 'gtk3' 'cmake' 'sdl2' 'make')
provides=("neovide")
conflicts=("neovide-git")
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
- "0001-Remove-unnecessary-braces-around-if-condition.patch")
+ "0001-Remove-unnecessary-braces-around-if-condition.patch::https://github.com/Kethku/neovide/commit/c4890065a33ac265184400ab83743702efbaf291.patch")
sha256sums=('4daaad6ff527c299b9fa3db677bc1320b9596efbc27853ed730a57df6c1568fd'
- 'aa9a7032a38f14c445e343c672e87b8128625f87132461c87cae42377e34841c')
+ 'cfd5f5fa8015b377153d60515f2d797b9241d8df60633cfd85c9a24204541d9b')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -t -p1 < "${srcdir}/0001-Remove-unnecessary-braces-around-if-condition.patch"
+ patch -c -p1 < "${srcdir}/0001-Remove-unnecessary-braces-around-if-condition.patch"
sed -i 's/debug = true/opt-level = 3\ndebug = false/' Cargo.toml
sed -i 's/Icon=neovide/Icon=nvim/' assets/neovide.desktop
}