summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSainnhe Park2021-03-26 18:36:00 +0800
committerSainnhe Park2021-03-26 18:36:00 +0800
commit9dbe9cd9004e8bb3916aee03aea7f8e27872bf62 (patch)
treeffc4ae56aa74e7b0f71f5ac9f5126f7bcd048ceb /PKGBUILD
parent02059b1da7a6ac0759a230f1cfd1c30b7a06c557 (diff)
downloadaur-9dbe9cd9004e8bb3916aee03aea7f8e27872bf62.tar.gz
Compile from master branch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d1c72780c81..29d153113297 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=neovim-coc-git
-pkgver=0.0.79.r36.g815d105f
+pkgver=0.0.80.r44.g67fb4d13
pkgrel=1
pkgdesc='Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode'
arch=('any')
@@ -9,19 +9,24 @@ license=('MIT')
depends=('neovim' 'nodejs')
optdepends=('npm: for installing coc extensions'
'yarn: for installing coc extensions'
- 'watchman: for workspace_didChangeWatchedFiles feature'
- 'neovim-coc-extras-meta: some basic extensions')
-makedepends=('git')
+ 'watchman: for workspace_didChangeWatchedFiles feature')
+makedepends=('git' 'yarn')
provides=('neovim-coc')
conflicts=('neovim-coc')
-source=('git+https://github.com/neoclide/coc.nvim.git#branch=release')
+source=('git+https://github.com/neoclide/coc.nvim.git#branch=master')
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/coc.nvim"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe release --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "${srcdir}/coc.nvim"
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache"
+ yarn run build
+}
+
package() {
cd "${srcdir}/coc.nvim"
nvim -es --cmd ":helptags doc" --cmd ":q"