summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSainnhepark2020-08-03 18:37:55 +0800
committerSainnhepark2020-08-03 18:37:55 +0800
commitabed83db312b93a07a0ea301d7bbe2a84f3c37be (patch)
treec33f6618c92d4dbded86d65ce0846a1f39dc64fc /PKGBUILD
parent089b0b03ddafe61129cabb84482c8df5626b4027 (diff)
downloadaur-abed83db312b93a07a0ea301d7bbe2a84f3c37be.tar.gz
remove hook
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d2bd28b93235..380a9c53460d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,30 +9,23 @@ license=('MIT')
depends=('neovim' 'nodejs')
optdepends=('npm: for installing coc extensions'
'yarn: for installing coc extensions'
- 'neovim-coc-extras-meta-git: some basic extensions')
+ 'neovim-coc-extras-meta: some basic extensions')
makedepends=('git')
provides=('neovim-coc')
conflicts=('neovim-coc')
-source=('git+https://github.com/neoclide/coc.nvim.git#branch=release'
- 'coc-neovim-doc.hook')
-sha256sums=('SKIP'
- '2e4d498a34a920452764dffb728cd65526bff7bfbda8599f4de5b5ff427d8d5b')
+source=('git+https://github.com/neoclide/coc.nvim.git#branch=release')
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/coc.nvim"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd "${srcdir}/coc.nvim"
- touch doc/tags doc/tags-cn
-}
-
package() {
cd "${srcdir}/coc.nvim"
+ nvim -es --cmd ":helptags doc" --cmd ":q"
find autoload bin build data doc package.json plugin -type f -exec \
install -Dm 644 '{}' "${pkgdir}/usr/local/share/nvim/site/pack/coc/start/coc.nvim/{}" \;
install -Dm 644 "${srcdir}/coc.nvim/LICENSE.md" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
- install -Dm 644 "${srcdir}"/coc-neovim-doc.hook "${pkgdir}"/usr/share/libalpm/hooks/coc-neovim-doc.hook
}