summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 17:10:44 +0800
committerSainnhepark2020-07-28 17:10:44 +0800
commit01ef190212d2efb164f10f12f8c64271c5652e6d (patch)
tree393b8f1d9b0616c682f1b4271ac1f77df0afcba6 /PKGBUILD
parent7f2a5d0524d77d48494cccfa123430c320742201 (diff)
downloadaur-01ef190212d2efb164f10f12f8c64271c5652e6d.tar.gz
update build()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5bc3f49d265b..c1f714b02d02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,10 +25,16 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
yarn install --frozen-lockfile
+ yarn pack --frozen-lockfile --production
+ tar xvf *.tgz
+ rm *.tgz
+ cd package
+ npm install --only=production
}
package() {
- cd "${srcdir}/${_extname}"
- find lib/*.js package.json -type f -exec \
+ cd "${srcdir}/${_extname}/package"
+ find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ rm -rf "${srcdir}/${_extname}/package"
}